Java-Kompatibilitäts Matrix

From SEPsesam
Revision as of 09:42, 11 March 2024 by FuzzyBot (talk) (Updating to match new version of source page)
Other languages:


Docs latest icon.png Willkommen in der aktuellsten Version der SEP sesam Dokumentation 5.1.0 Apollon. Frühere Versionen der Dokumentation finden Sie hier: Documentation Archiv.


Unterstützte Java Versionen


Das SEP sesam GUI ist plattformunabhängig - es basiert auf Java und benötigt eine Java-Laufzeitumgebung (JRE). Die benötigte Java Version hängt von der SEP sesam Version ab.

Java wird auf allen Systemen benötigt, die als SEP sesam Server, SEP sesam GUI Client oder SEP sesam Remote Device Server (RDS) dienen, wenn Si3 Deduplizierung verwendet wird.
Java ist nicht erforderlich für einen SEP sesam Client (stellt keine GUI zur Verfügung) oder SEP sesam RDS, wenn die Si3 Deduplizierung nicht verwendet wird.

  • Unterstützte Java Versionen sind: Oracle/Sun Java, IBM Java und OpenJDK LTS.
  • Anmerkung

    Öffentliche Updates sind für Java SE 8 nicht mehr ohne kommerzielle Lizenz verfügbar. Außerdem ist die Oracle JDK-Binärdatei seit JDK 11 nicht mehr kostenlos für den produktiven Einsatz, sondern nur noch mit einem Support-Vertrag. Weitere Informationen finden Sie unter Oracle Java SE Support Roadmap.
    Sie können eine kostenlose OpenJDK LTS-Version anstelle von Oracle Java verwenden. Sie können OpenJDK unter Linux oder Windows einfach OpenJDK installieren, wie in SEP sesam Installation - Kurzanleitung beschrieben.

  • Oracle Java können Sie unter Java Downloads für alle Betriebssysteme herunterladen.
  • Auf Windows Systemen können Sie mit JAVA Verifizierung überprüfen, welche Java Version installiert ist.
  • OpenJDK LTS wird von den jeweiligen Linux Distributionen zur Verfügung gestellt.
  • OpenJDK LTS Java können Sie unter OpenJDK LTS Download herunterladen.

Die folgende Tabelle zeigt die Kompatibilität zwischen Java und SEP sesam Versionen.

SEP sesam version Java version
5.1.0 Apollon [V2] Java 17 Note1, Java 11, OpenJDK 11 LTS
5.0.0 Jaglion V2 Java 17 Note1, Java 11, OpenJDK 11 LTS, Java 8 ≥ patch level 111 (both Windows and Linux) Note2 Note3
5.0.0 Jaglion Java 11, OpenJDK 11 LTS, Java 8 ≥ patch level 111 (both Windows and Linux) Note3
4.4.3 Beefalo V2 Java 11, OpenJDK 11 LTS, Java 8 ≥ patch level 111 (both Windows and Linux)
Anmerkung1
  • Unter Windows empfiehlt SEP sesam Java 17.
  • Unter Linux, SEP sesam ≥ 5.0.0.9 Jaglion V2 and 5.1.0 Apollon, unterstützt Java 17 nur bei Bedarf, wenn die Verwendung von Java 17 von der Kommandozeile mit sm_setup set_java_path -f <java_17_installation_path> aktiviert wurde.
Anmerkung2
5.0.0.9 Jaglion V2 ist die letzte Version von SEP sesam, die Java 1.8 unterstützt.
Anmerkung3
Java 1.8 (≥ 1.8.0_111) wird nur akzeptiert, wenn es bereits installiert ist und der Computer nicht über einen 4K-Bildschirm verfügt.