Java Compatibility Matrix

From SEPsesam
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.
This page contains changes which are not marked for translation.
Other languages:
Copyright © SEP AG 1999-2022. All rights reserved.

Any form of reproduction of the contents or parts of this manual is allowed only with the express written permission from SEP AG. When compiling and designing user documentation SEP AG uses great diligence and attempts to deliver accurate and correct information. However, SEP AG cannot issue a guarantee for the contents of this manual.

Docs latest icon.png Welcome to the latest SEP sesam documentation version 4.4.3 Beefalo V2/5.0.0 Jaglion. For previous documentation version(s), check documentation archive.


Supported Java versions

The SEP sesam GUI is platform independent – it is based on Java and requires a Java Runtime Environment (JRE). The required Java version depends on the SEP sesam version.

Java is required on all systems that serve as SEP sesam Server, SEP sesam GUI client or SEP sesam Remote Device Server (RDS) when Si3 deduplication is used.
Java is not required for SEP sesam Client (does not provide GUI) or SEP sesam RDS if Si3 deduplication is not used.

  • Supported Java editions are: Oracle/Sun Java and OpenJDK LTS.
  • Note

    Public updates for Java SE 8 are no longer available without a commercial license. Also, as of JDK 11, the Oracle JDK binary is no longer free for production use, but only with a support contract. For details, see Oracle Java SE Support Roadmap.
    You can use a free OpenJDK LTS version instead of Oracle Java. You can easily install OpenJDK on Linux or Windows, as described in SEP sesam Quick Install Guide.

  • You can download Oracle Java at Java downloads for all operating systems.
  • On Windows systems, you can use JAVA verify to check which Java version is installed.
  • OpenJDK LTS is provided by the respective Linux distribution.
  • You can download OpenJDK LTS Java at OpenJDK LTS Download.

The following table shows the compatibility between Java and SEP sesam versions.

Java version SEP sesam version
Java 17 on demand Note1
OpenJDK 11 LTS 4.4.3 Beefalo, 5.0.0 Jaglion, 5.0.0.9 Jaglion V2 Note2
Java 11 4.4.3 Beefalo, 5.0.0 Jaglion, 5.0.0.9 Jaglion V2 Note2
Java 10 is not supported!
X
Java 9 is not supported!
X
Java 8 ≥ patch level 111 (both Windows and Linux) 4.4.3 Grolar; 4.4.3 Beefalo, 5.0.0 Jaglion, 5.0.0.9 Jaglion V2 Note2
Java 8 (at least patch level 111) ≥ JRE 1.8.0_111 (required for Linux) v. ≥ 4.4.3 Tigon V2
Java 8 (required for Windows) v. ≥ 4.4.3
Java 7 (all OS except Windows) 4.4.3 Note3
Java 7 4.4.2
Java 6 4.2.1 & 4.2.2
Note1
  • SEP sesam 5.0.0.9 Jaglion V2, including SP1, supports Java 17 only on demand, if the use of Java 17 from the command line has been enabled with sm_setup set_java_path -f <java_17_installation_path>
Note2
  • Java 1.8 (≥ 1.8.0_111) is only accepted if it is already installed and the computer does not have a 4K display.
  • 5.0.0.9 Jaglion V2 is the last version of SEP sesam that supports Java 1.8.

Note3

SEP sesam versions 4.4.3 until 4.4.3 Tigon V1 running on non-Windows platform require Java 7, however, SEP sesam uses JavaFX for its web dashboard and user-defined schedules features. If you want to have all the 4.4.3 features available, you need OpenJFX package or Oracle®'s Java 8 (already includes JavaFX) on your SEP sesam GUI client.