Java Compatibility Matrix

Other languages:


Docs latest icon.png Welcome to the latest SEP sesam documentation version 5.1.0 Apollon. For previous documentation version(s), check documentation archive.


Supported Java versions


The SEP sesam GUI is platform independent – it is based on Java and requires a Java Runtime Environment (JRE). The required Java version depends on the SEP sesam version.

Java is required on all systems that serve as SEP sesam Server, SEP sesam GUI client or SEP sesam Remote Device Server (RDS) when Si3 deduplication is used.
Java is not required for SEP sesam Client (does not provide GUI) or SEP sesam RDS if Si3 deduplication is not used.

  • Supported Java editions are: Oracle/Sun Java and OpenJDK LTS.
  • Note

    Public updates for Java SE 8 are no longer available without a commercial license. Also, as of JDK 11, the Oracle JDK binary is no longer free for production use, but only with a support contract. For details, see Oracle Java SE Support Roadmap.
    You can use a free OpenJDK LTS version instead of Oracle Java. You can easily install OpenJDK on Linux or Windows, as described in SEP sesam Quick Install Guide.

  • You can download Oracle Java at Java downloads for all operating systems.
  • On Windows systems, you can use JAVA verify to check which Java version is installed.
  • OpenJDK LTS is provided by the respective Linux distribution.
  • You can download OpenJDK LTS Java at OpenJDK LTS Download.

The following table shows the compatibility between Java and SEP sesam versions.

SEP sesam version Java version
5.1.0 Apollon [V2] Java 17 Note1, Java 11, OpenJDK 11 LTS
5.0.0 Jaglion V2 Java 17 Note1, Java 11, OpenJDK 11 LTS, Java 8 ≥ patch level 111 (both Windows and Linux) Note2 Note3
5.0.0 Jaglion Java 11, OpenJDK 11 LTS, Java 8 ≥ patch level 111 (both Windows and Linux) Note3
4.4.3 Beefalo V2 Java 11, OpenJDK 11 LTS, Java 8 ≥ patch level 111 (both Windows and Linux)
Note1
  • On Windows, SEP sesam recommends Java 17.
  • On Linux, SEP sesam versions ≥ 5.0.0.9 Jaglion V2 and 5.1.0 Apollon support Java 17 only on demand, if the use of Java 17 from the command line has been enabled with sm_setup set_java_path -f <java_17_installation_path>.
Note2
5.0.0.9 Jaglion V2 is the last version of SEP sesam that supports Java 1.8.
Note3
Java 1.8 (≥ 1.8.0_111) is only accepted if it is already installed and the computer does not have a 4K display.